Top 10 Install Problems – Part 1

Written by Jim Stokes – Warranty Technician

Jim has held many titles in his 12 years at Certified Transmission.  He’s been a service writer, diagnostician, helped run Certified shops, and has now been a part of the warranty team for almost 10 years.

 

Our company sells hundreds of wholesale carry-out units, as well as performing thousands of in-house installations.  Our talented team of technical advisers provides guidance for both types of installs, and we’ve found a number of common issues that installers face on a daily basis. In this two-part series, we will be exploring the top 10 install problems we encounter.

1.  Software updates, clearing shift-adapts, and performing relearn procedures

Software Updates

Hands down, updating PCM/TCM software corrects more problems than anything else.  It just makes sense that the OEM software may not operate the transmission as originally intended, and adjustments have to be made to correct problems.  Where it gets tricky is when the factory doesn’t publish an update on a TSB to notify technicians that a change has been made.  For that reason, the latest updates should always be installed when a replacement transmission is being installed.

Shift-Adapts

Shift adapt strategies have been common for well over a decade now.  When a unit is failing, the PCM/TCM will be constantly trying to compensate for the slipping or harsh shifts produced by internal unit failure.  Any time a transmission is rebuilt or replaced, the shift-adapts must be cleared.  A few years ago, disconnecting the battery would clear the shift-adapts in most vehicles, but this is no longer the case.  Often an OE factory scan tool is required.  There are many aftermarket scan tools that have adapt-clearing functions, but the results are not always effective.  Only a factory scan tool can guarantee results every time.

As an example, we had a 2005 Mitsubishi Montero with a fresh reman unit installed that had a 1-2 shift flare and a harsh 2-3 shift.  The installing shop had a new, aftermarket, top-of-the-line scan tool that had a function test for clearing shift adapts.  The tech had performed the shift-adapts clearing procedure prior to calling in the claim.  After attempting a cleaning of the MAF sensor and trying to tweak the TPS adjustment without favorable results, we sent the installer a replacement transmission.  The replacement unit had the exact same shifting problems, so we had the vehicle taken to the Mitsubishi dealer to have the shift-adapts cleared.  After the procedure was performed with OE equipment, the unit worked perfectly.

Relearn Procedures

After the shift-adapts are cleared, some units will function normally right away while others must learn how to shift properly.  Some must also learn how to engage into forward and reverse without excessive bump.  There is a procedure known as “garage shifts” that involves engaging the unit into reverse five times with a 5-second interval, and the same into forward.  In some cases, this is all that’s required.  The upshift relearn is normally performed with 5-10 shift cycles through all gears at 20-25% throttle angle.  Some manufacturers require more complicated procedures, so research may be required for specific vehicles.

 

2.  Details in set-up procedures

Throttle Cables

Though these units haven’t been in OE production for over a decade, they are still very popular:

THM700R4/AOD

There is only one way to properly set up these units to shift correctly (and make them survive): a pressure gauge.  If you call in a claim on one of these units, the first words you will hear from us are, “What is the pressure reading at factory idle speed?”  If you don’t have the answer, we will request a call back with that information.  This is a critical setting for these units and use of a pressure gauge is the only sure way to get it right.

Most other types of units utilizing a throttle cable are much simpler to set up, as they only require synchronized TV movement with the engine throttle.  On the Chrysler RWD vehicles, make sure that there is a return spring on the throttle lever (at the transmission), or you will end up with harsh downshifts.

Range Sensors/MLPS

Ford Explorers equipped with the 5R55W/S transmission seems to have the most claims that are generated due to MLPS problems.  The most common symptom is delayed or no reverse engagement.  In most cases this can be corrected with a simple adjustment of the sensor. Ford specifies a special tool for the adjustment, but some shops aren’t going to have access to one.  One workaround is to monitor PID data on a scanner. Using the scanner, go to “live data” and find the digital signal PID from the sensor; it is four binary digits.  With the shift cable disconnected, shift to neutral at the transmission lever and adjust the switch to a signal of 0110, then shift to REV and look for a signal of 1100, and finally to DRIVE and look for 1111, if you don’t see these number sequences, replace the switch and adjust again.  Shift back to neutral at the transmission and put the column lever in neutral, then adjust the cable so that it lines up exactly with the shift lever.

Honda units have a unique problem with their gear position switches.  Symptoms of problems with the switch can include no reverse, no forward upshifts, or neutralizing when accelerating from a stop.  A common cause of these symptoms is the manual shift shaft getting damaged during the installation.  The shaft is slotted to accommodate the switch actuator notch.  The shaft can get pinched together during installation of the unit, and the switch cannot engage with the pinched slot. The diagram below shows the shaft:

 

3.  PCM/TCM

1993-1995 GM trucks with 4L60E/4L80E transmissions

A common problem with these ECMs is high line pressure that generates customer complaints of harsh 1-2 shifts.  Typically, line pressure at factory idle speed will be 110-140 psi, and rise to 160-170 with higher engine RPM.  This is normal pressure that occurs due to higher pump output caused by the increased engine speed.  To diagnose a high line pressure condition, use an amp probe or meter hard-wired into the return circuit of pin D of the case connector at the ECM connector harness.  Compare the actual amp reading to the scanner actual reading.  Typically, if the ECM is faulty, you will see amp meter readings from 0 to 0.3 amps, and scanner command readings of 1.0-1.1 amps.  If the readings don’t match (as per this example), the ECM is the problem.  Lately we have had some late model 1997-2001 vehicles with the same problem, and the diagnosis process is the same.

722.6

We had a 2005 Sprinter setting several codes pertaining to GRE, solenoid electrical and performance, and speed sensors that was difficult to diagnose.  We had the shop ohm testing circuits and also load testing them with a headlight.  This went on for about a week and a couple of calls a day without any progress.  I was working on another problem vehicle when I found Wayne Colonna’s article in the 06/07 TD, “Coping with Capillary Action”.  I immediately called the shop and had them remove the TCM from under the seat, and they found that it was full of fluid.  We had them install a new TCM and seal the wire harness with solder, and the unit worked great after the repair.  We still find this to be a continual problem with the Sprinter vehicles.  We have seen TCM replacements also correct problems with GRE codes and no shifts past 2nd gear, though no fluid was found in the TCM.

2000-2004 Jaguar S-type, 2000-2003 Lincoln LS, and Ford Thunderbird

These vehicles can develop a pressure control problem with complaints of harsh engagement, harsh up-shifts from 1st to 2nd, and 3rd to 4th, and harsh 2-1 coast downshifts.  Pressure readings can be in the 170 psi range at factory idle speed.  Idle speed is an important factor, as many of these vehicles have issues with high idle speed due to a faulty throttle body.  Another common cause is a bad PCM.  To diagnose it, the best tool for the job is an amp probe.  If the actual readings measured on pressure control solenoid ‘A’ don’t match the PCM command, the PCM is faulty and will require replacement.  The OE dealers do not usually stock these PCMs, and they are quite expensive.  We have had shops report successful repairs from independent repair facilities that have the ability and equipment to repair the PCMs internally, and reprogram them to work properly.  We don’t have the luxury of this service here in the Midwest, but on the Coasts, there are techs in the business.

Toyota/Lexus

RAV4, RX300 series, Corolla, Matrix, and Pontiac Vibe are having PCM-induced transmission problems, primarily around 1999 to 2004 m/y vehicles.  The most common issues are seen with the RAV4 vehicles, and Toyota has issued T-SB-0156-10 that addresses the problem.  There is a revised PCM part number to resolve the shifting issues.  The primary concerns involve the 2-3 shift with a bind-up, or a spin-up with a double-bump.  Lately we have seen several Lexus RX300 series vehicles with this same concern, but there aren’t any published technical information documents from Lexus that address it.   It doesn’t take very many shift cycles to damage the direct clutch in the transmission, and eventually the clutch fails.  Replacing the PCM seems to be the answer, similar to the Toyota repair.

 

4. Electrical connectors

Vehicle harness connectors can have multiple problems: little to massive amounts of corrosion, loose pin fitment and fretting, broken lock tabs, and seized connectors that won’t unplug from the transmission connector.

E4OD/4R100 units seem to have the most connector problems, and with the exception of seizure, they seem to have all of the other concerns.  The lock tab is very easy to break and causes poor electrical contact, DTCs, and overall performance problems.  It isn’t uncommon to get a call with an electrical circuit code.  I will usually send a replacement solenoid pack when this happens to eliminate the transmission as a cause first.  Often times I get another call after the replacement solenoid pack is installed with the same code, or a different circuit code.  After some coaxing the customer will finally admit that the lock tab is broken from the harness.  I see a lot of corrosion from these connectors also and it seems to be worse on the east coast, but recently had a customer in Iowa that had returned the “defective” solenoid pack and connector. It was so badly corroded that the pins in the solenoid pack were eaten away to nothing in a short, 4-week time frame.

Ford 5R55S-W-N units use a bolt-in connector that is very difficult to remove from the solenoid pack at times.  We have had some shops successfully remove the connector with the help of a heat gun.  Last I checked there weren’t any replacement connectors readily available in the aftermarket, and use of a Ford part requires replacement of the entire harness, as the connector is included with it.

Cross-connecting shift solenoids and sensors has been an ongoing issue for a while now, but never seems to be getting any better.  It could be assumed that, because of the cost-savings of using the same connectors in multiple locations, the OE chooses to manufacture some cars in this fashion.  I first ran into the problem about 16 years ago. I had replaced the engine harness and several sensors on a 1996 Accord that had an under hood fire.  The engine would start but wouldn’t idle, or run even with the throttle applied.  It turns out that I had the MAP sensor and the TPS cross connected.  Hondas still have this problem today, because many of the shift solenoids and sensors use the same connector, as do the pressure switches.  If they have the same pin count in the connector, it will plug into the wrong component and cause issues.

Mitsubishi and Hyundai vehicles also have the same problem, usually with (but not restricted to) the pulse generators.  Mixing up these sensors can have multiple issues, including no reverse, wrong gear starts, and no upshifts.  Color matching the harness connectors will often find the problem quickly, but not always.

Just recently we had a 2008 Mazda Tribute that had a long, delayed reverse engagement, and was hunting in and out of 2nd and 3rd gear.  The vehicle had been driven only 5 miles after installing the transmission.  We were about to ask him to send the unit back to us, but then the customer revealed that the speedometer was reading much slower than it used to.  It turned out that he had the connectors crossed for the input and output speed sensors.  After that was corrected, the unit worked fine.

Having a component locator available to view along with a good wiring diagram will usually help sort this type of problem out in a short amount of time.

Next month, in Part 2, we’ll cover 5 through 10 of the Top 10 Install Problems.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s