Volumetric Efficiency Helps Pinpoint MAF Issues

By Chris Adams, Diagnostician

adams-chris-2Chris Adams started with Certified Transmission in 1986 as an R&R technician, and currently works as our Diagnostic Trainer. His current duties involve training and advising our retail diagnosticians, as well as assisting in the research and development of our remanufactured products. He also holds ASE Master and L1 certifications.

For this installment of R&R Tech I would like to take some time to discuss how engine performance can affect the transmission operation. We have all heard it before; the engine must be running properly in order for the transmission to function correctly. What “properly” mean in this scenario? We all use different terms when we tell the customer, “You need to get the engine running properly”, or good, correct, better, whatever terms we use; in our mind it all means the same thing. We either see or feel something that is not right with the engine performance and to try to protect our investment (our remanufactured product) by telling the customer that it needs to get repaired in conjunction with the transmission replacement. How far do we need to go with this? Just tell the customer and leave it up to them, or do we require them to have it checked/repaired and return it to us for inspection?

I suppose it would depend on the severity of the issue, but for the most part we require that the customer return the vehicle to us for verification of repairs. One of the easiest things we deal with is a simple DTC related to a sensor issue, for example, an O2 sensor code. We can make sure that the code has not returned, check Mode 6 data, and make sure that the monitor has completed. There are others that are a little more difficult, perhaps more time-consuming for us to verify. This is one story that I feel is a perfect example of this and why it is so important that everything with the vehicle is in proper running condition.

Our test subject: a 2006 Chevrolet K1500 with a 5.3L engine and 4L60E transmission. This vehicle arrived at one of our facilities with a 2-3 neutral condition. We installed a remanufactured transmission, re-programmed the PCM, and road-test. Everything seemed to work well: engine running fine, no DTCs, and fuel trims are less than 10% total. Everything looks good so we deliver the vehicle to the customer.

About 10 months and 12K miles go by and the truck returns with really poor shift quality. The transmission slides through the 1-2 shift and flares on the 2-3 shift. The fluid has somewhat of a burnt smell to it, and now the PCM has a P0101 MAF code in it. We replaced the transmission under warranty and recommend that the MAF sensor be replaced. The customer declines the MAF sensor replacement and says that he will take care of it himself. This is where we dropped the ball. We should have pressed the issue and done the work ourselves. The customer later returned for a follow-up visit, but the Diagnostician that originally road-tested the truck was away on vacation. The Tech looks at the truck, verifies that the MAF sensor was replaced so we send the customer down the road again.

As I was reviewing warranty claims, this case caught my eye. Looking further into it I found out that all we did actually did was verify that the MAF sensor was replaced, and no one could even tell me what brand it was replaced with. I knew that I needed to have the customer return yet again for us to verify further. If we didn’t, we would risk damage to the replacement transmission.

The understanding customer dropped off the vehicle so we could do some more in-depth testing. The MAF sensor was a new one from Delphi, and the receipt was still in the truck. The cost was around $130. I knew what an AC Delco sensor costs, so that was my first red flag. The truck did seem to run okay, fuel trims are still less than 10% total, and no DTCs. The next step was to monitor the transmission line-pressure with a gauge, and PIDs with the Tech2Win laptop.

The line pressure tests at idle and stall were both within specs (ours do run a bit higher with modifications that are done inside the unit), and under normal driving conditions, everything seemed to work well. Enroute to a road with a higher posted speed limit, I performed a WOT test while in 2nd gear and at WOT I was a little concerned that the line pressure did drop a bit while pulling through 2nd gear, but just looking at the live data nothing really stood out to me.

I have been to many training seminars and one that I learned quite a bit about engine performance testing was from “The Driveabilty Guys”. There is a “Volumetric Efficiency Test” that I have used and works very well. To do the VE test, you have to make a WOT pull through a gear change whether it be the 1-2 or 2-3 and record certain data pids on the scan tool. The reason I used the Tech2Win is it has a fairly fast sample rate as compared to some aftermarket scan tools. I also make two runs under the same conditions, just to make sure that the data is valid.

This is a screenshot of engine parameters during a WOT pull up to the 2-3 shift. The cursor (small white arrow at the bottom) is stopped at max RPM of 5665, MAF reading of 202.25 g/s, and ECU calculated (scan tool data) engine load of 85%, varying between 80% and 91% through the pull.

fig1

Figure 1

These are the transmission data pids I recorded on the exact same stretch of road while under the same operating conditions. The PCS duty cycle is running at 38%, both the actual and reference current is sitting at .72 amps at WOT pulling through 2nd gear, and on the pressure gauge this was about 150psi (this does not match the pressure to current charts for a OE transmission because of our modifications to the line pressure circuit).

fig2

Figure 2

I got back to the shop to go over the recorded data and gather everything needed to use the VE calculator (there is a phone app that works well, or online versions available found with Google). The VE calculator requires the engine displacement in liters, mass air in g/s, max RPM, and IAT reading. Using the data I recorded and inputting it into the VE calculator, the two different readings I took showed 73% and 68% efficiency, where minimum spec is to be 80% I suspected that there wais a bit of MAF degragation but honestly just by driving the vehicle you probably would not notice it. I decided to buy a AC Delco MAF sensor just to test with and see if I have different results.

I reran the same tests, and honestly, I was a little bit surprised at the results.

fig3

Figure 3

This image shows the same parameters as figure 1, and the cursor is stopped at max RPM of 5651, MAF reading of 239.82 g/s, and ECU calculated load of 96% varying between 93% and 100%. Using the VE calculator, the two different readings I took showed 83% and 84% efficiency, and therefore within spec. Idle and stall line pressure readings were still the same, but during the WOT pull through 2rd gear the line pressure was 30 psi higher than before replacing the MAF sensor.

In the following image, these are the same transmission PIDs as displayed in figure 2. The PCS duty cycle is running at 32% and both the actual and reference current is sitting at .60 amps while the pressure gauge was showing about 180 psi. All these recordings were taken from the same stretch of road and the same outside air temperature.

fig4

Figure 4

The operation of the transmission was also noticeably different; the shifts were firmer, the TAP cell numbers dropped (sorry I did not save a screenshot of that), and the line pressure was more responsive in addition to the 30psi higher reading while driving it. I was really surprised that this had no affect on line pressure during the stall test, so it just goes to show that the old way of doing things simply won’t cut it in this day and age, and this is just a 4L60E!

Curiosity got the best of me, so I wanted to know if this was possibly just the result of a bad MAF sensor from Delphi. I got another brand new Delphi sensor under warranty, reran the same tests on the same stretch of road at the same (close) air temperature, and got almost the same exact results as the first Delphi sensor. I can only say that the base calibration of the Delphi sensor is just not quite right, perhaps just enough to have an adverse affect of the operation of the engine and transmission.

I am happy to say that the customer had just returned for a service and has 30k miles on it since we installed the last transmission and everything is working properly. He also stated that he noticed improved fuel mileage since we installed the OE MAF sensor and was happy that we took the extra steps to make sure his vehicle was repaired correctly. I kind of forgot about this one until he returned, so I am glad I saved the screenshots and notes from this vehicle; we use these types of examples for our own internal training.  I encourage you to try the VE testing and see what you come up with. You don’t have to do it on every vehicle with a MAF sensor, but do look at the engine load % on your scan tool and if you see one that is low, do the VE test and I can just about guarantee you will be surprised at the results.

Please keep in mind that a failed/skewed MAF sensor is not the only thing that can affect VE; clogged intake, clogged exhaust, or poor fuel delivery can also cause these same issues.

Advertisements