Transmission Issue Creates Symptoms In Other Vehicle Systems

By Sean Mahoney, Diagnostician

mahoney-seanSean has been a member of the Certified Transmission team for five years. He is ASE-Certified and enjoys the challenges that come with diagnosing vehicle problems.

A while back we had a customer come into our shop stating, “The vehicle sometimes has a VSC (Vehicle Stability Control) error and won’t go past fourth gear, but today it seems fine.” The vehicle was a 2007 Lexus LS460 with 132,561 miles, and equipped with an AA80E 8 speed transmission and a 4.6L engine. As with routine diagnosis, I started with a road test, a scan of all modules, and an undercar inspection.

The scan procedure came back with four DTCs: P0771 (shift solenoid ‘E’ performance), P0796 (pressure control solenoid ‘C’ performance), and P2714 (pressure control solenoid ‘D’ performance). There was also an unrelated HVAC code stored. Because there were no VSC or ABS diagnostic trouble codes present, when the check engine light was illuminated the system was possibly turning the VSC system, but at this point it is too early to rule anything out.

On the road test I backed out of the parking spot and started on my normal route. At the first stoplight the transmission clunked into gear while coming to a stop, and when I accelerated I could tell the transmission was in a higher gear. Oddly enough, the vehicle would try to shift once in a while after taking off from a stop, but most of the time the transmission stayed in third gear.

fig1

Figure 1

As I pulled the vehicle into the bay door to do an undercar inspection and to finish my initial evaluation, I put the car in reverse and had a 5 second delay followed by a very, very hard reverse engagement. I tried to duplicate the delay a few more times with varied results, sometimes it went into gear with no issues and sometimes it had a hard delayed reverse engagement. Underneath the vehicle I checked the fluid (which was dark) and I noticed that the wiring coming out of the transmission connector looked oily. Even though the VSC light didn’t illuminate on the initial test drive, I could tell there was still a problem that needed to be addressed. Due to the oil-soaked harness and the solenoid codes it was time to recommend further testing. The customer agreed and left the vehicle with us to proceed.

I wanted to get as much technical information about this transmission (even if it was unrelated to my problem) before I went any further. I took a look at the diagnostic trouble code information and flow charts, and surprisingly the information for P0771 and P2714 directed me to start with P0796 (pressure control ‘C’ performance code) if all three DTCs were present. I started with a simple battery and alternator test, which the vehicle passed. Next, I raised the vehicle back up and proceeded to disconnect and inspect the transmission connector more closely due to the possible fluid weeping through. As I thought, the ATF was pushing through the connector.

fig2

Figure 2

fig2a

Figure 2A

Curiosity got the best of me and I unplugged the transmission harness, let the vehicle down and shifted between park and drive to reverse multiple times. Just as I assumed, I had a reverse engagement every time, albeit very firm and quick, as expected. I carefully disassembled the connector cleaning it with electrical contact cleaner (Deoxit D5), and dried out the connector socket at the transmission. I started next, with checking for B+ at the ECM connectors for the solenoids, next I removed the E6 and E7 connectors from the TCM and started with a simple resistance test through the solenoid circuits.

fig3

Figure 3

The specification for the SLT (P2714) and SL3 (P0796) solenoids (which are linear solenoids) is 5.0-5.6 Ω, and 11-15 Ω for the SR (P0771) solenoid which is one of the two on/off solenoids in the transmission. I found 5.6 Ω at the SLT solenoid and 5.5 Ω at the SL3 solenoid. Both were in spec, but the SR solenoid showed 47.3 Ω when checked. Next, I checked resistance from the transmission connector to the TCM connector to make sure my SR solenoid wiring wasn’t shorted to ground anywhere. I found .3 Ω from the transmission connector to the TCM connectors on all three solenoid circuits. I knew that the probable cause of my problem was the SR solenoid, but since I was already at the TCM and had my scope handy I wanted to see if I could watch the three solenoids before while getting the vehicle to act up.

fig4

Figure 4

When reverse was engaged the SR solenoid dropped from 12v to 0v which showed it was being pulled to ground as it should be. After removing the pan, the SR solenoid checked directly at the solenoid was 47 Ω. I conceived my recommendation: replace the SR solenoid and the internal wiring harness to address the customer concern and the connector leak.

Even though the case connector has plenty of clearance between the valve body and case, the valve body still needed to be removed to unplug sensor wiring above the valve body.

fig5

Figure 5

I removed the filter and unplugged the solenoids. Next, I removed the e-clip that secures the manual valve. There are 17 bolts that needed to be removed, and 3 different lengths used holding the valve body to the case.

fig4

Figure 4

The spring and check ball body above valve body need to be accounted for when going back in. After installing the harness and putting the valve body back in, I installed the new SR solenoid which checked at 13 Ω like it should have. One thing to note is that the transmission fill procedure on this vehicle is very specific and too long to include in this article, so if you work on one of these units be sure to refer to service information when setting the fluid level.

After getting the transmission filled up, checked and rechecked again, I was ready to see how this vehicle is supposed to normally drive.

fig6

Figure 6

The vehicle shifted great, and after a few long road tests I was confident that the original issue was addressed and repaired, so the vehicle was then delivered to the customer.

One month later the vehicle returned to me with the customer complaint of, “The check VSC light is on, but it is shifting okay at this time.” This time the VSC light was illuminated along with the check engine light. A quick code scan revealed a P0171 (system too lean bank 1), and C1201 (engine control system fault) which sets the check engine light and the VSC light. It’s usually never a great thing when a vehicle comes back, but in this case I could verify the transmission operation over a longer period of time and refer the customer to a shop that could address his engine-related codes.

I wanted to bring attention to this one because one of the issues that we have seen lately is other shops not spending time to look at all things related to a warning light. This nearly identical circumstance had happened previously where the customer took his car to a transmission shop with the VSC light on and was referred to a general repair shop because, “We don’t work on that stuff” prior to even hooking up a scan tool. The customer then goes to a general repair facility where he is told that’s a transmission problem and, “We don’t work on transmissions”, and then finally to one of our locations where the customer issue is finally repaired. You can see how frustrating this could be for anyone getting this poor level of customer service. The takeaway is to know and understand the various systems that are involved in your diagnosis, and how they relate to each other.