2011 Ford F150 Electrical Diagnosis

By Mike Greer, Diagnostician

author10Mike has been with Certified Transmission since 1996, and been in the industry since 1987. He is an ASE master Technician and has served as a Master Builder for the company in the past.  

 

 

 

 

A customer recently brought his 2011 Ford F150 into our facility after a general repair shop (not a specialized transmission shop) had just installed a used transmission. His truck was a 4WD vehicle equipped with a 5.0L engine and 6R80 transmission. When the customer picked up the truck from the previous shop he was told that the transmission was installed and everything was fine, but it still needed to be programmed (the shop didn’t have the equipment to perform this important step).

This is a fairly similar story that one of my colleagues wrote about a few months ago about a Jeep, but with a couple of added twists. We are seeing programming requests like this more often with the 6 and 8-speeds that are showing up at our stores as the 6-speed applications are aging, and with the higher mileage put on these vehicles, we seem to have more customers trying to get by with the cheapest options that are out there. Customers are turning to general repair shops with lower labor rates, and elect to install used parts from unknown origins or mileage instead of having a professional transmission tech repair, rebuild, or replace the transmission with high-quality components.

When this customer showed up at our facility and told the service advisor the whole story, we knew it was not going to be as simple as, “The shop that installed it said it needed to be flashed.” The customer stated that he went to the other shop with a complaint of a check engine light on, no power from a stop, and no shifting. Can you guess what symptoms were after the used unit was installed? You guessed it…a CEL light on, no power from a stop, and no shifting.

When I started the evaluation and scanned the vehicle for codes, it had P0657, P0770 and P0773 stored in memory <FIG 1>. I had no way of knowing whether or not these codes were set in the system prior to the used transmission installation, or generated after. We told the customer that we would need a couple of hours of diagnostic time to pinpoint the issue. Since the diagnostic time was an added cost over and above the PCM programming, the customer requested that we simply program it first. After we made it clear that he would be charged for the programming even if it did not fix the issue, he acknowledged this and I proceeded forward with the customer request.

186a

I hooked up the Ford IDS scan tool and determined that there was a later calibration available. I proceeded to reprogram the module and it appeared to go through the steps normally, just like any other vehicle with this engine/transmission combo. Programming was successful, but when I went back to scan and clear codes I was shocked to see that now the PCM had 16 different codes stored and they appeared to be every possible solenoid electrical code that the system was capable of generating. What?! I went back to the programming screen and it displayed, “Later calibration available.” How could that be? I had just programmed it and had no errors! Reluctantly, I decided to run through the programming routine again. Unfortunately, I landed at the same result as before.

It would seem that I made the issue worse than when I began this adventure. Remember years ago when OBD2 was new and we were always told to fix the lowest numerical code first when there were multiple DTCs set? It just so happens that the lowest numerical code on this truck was one of the codes stored when it first showed up: P0657 (Actuator Supply Voltage ”A” Circuit Open), so let’s start there.

This next part would have been a little easier if I had printed off the correct connector view. While I knew that I needed C1381T, for some reason I printed off C1381E which was still a PCM connector and looked very similar to the “T” but the wire position of pin 50 was not in the same location. After a few minutes of trying to figure out why the wire color was not correct and why the PCM pin 50 seemed to be a ground rather than a B+ supply, I got the correct connector view and started over again.

I had B+ at pin 50 of the C1381T connector, but nothing down at the transmission connector pin 7. I performed a visual inspection which did not reveal anything out of the ordinary. Sometimes you see a missing wire harness retaining clip or it’s obvious that something had just been worked on, but I was a little surprised that the installation of this unit was actually very good; everything was put in its place just like OE, and I saw nothing that really raised suspicion. Since access to the wire loom was pretty tight I decided to remove the loom from the truck and work on it on the bench, and found this: Figure 2 & Figure 3 Below (in order).

186b

186c

The loom had rubbed through against the bellhousing just forward of the loom clip hole on the case. <FIG 4> shows where the loom was rubbing and wore through. After seeing where it was, I might have been able to repair it in the vehicle, but I still think it was a better repair off the vehicle. After the wire was repaired and the loom installed back into the truck, I was able to clear codes and none of them returned right away. I hooked up the IDS to check programming again, since the last programming session left me with “Later calibration available” displayed after programming. However, after repairing the loom, “No later calibration available” was displayed so I buttoned everything up and went for a road test. Hoping for the customer’s sake that everything was operational, the transmission worked well and no codes had returned. The customer stopped in a few days ago and wanted to thank us for repairing his truck correctly, and let us know everything had been working well.

186d

The question remains as to whether the original transmission was actually in need of replacement. All too often the shop makes assumptions and drives up the cost of repairs due to misdiagnosis. With modern vehicles that are more technologically advanced than ever before, we must take the time to find the root cause of customers’ vehicle concerns. This involves helping the customer understand why they will need to pay a few hundred dollars to diagnose; it could save them thousands. The days of a $50 diagnostic charge are long gone.